Service is disrupted
Incident Report for Holaspirit
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 08:58 UTC
Update
The service is back to normal, thank you for your patience and understanding
Posted Jul 01, 2023 - 08:58 UTC
Investigating
We are experiencing slow loading on pages and some errors. We appreciate your patience and feedback as we work to fix the issue.
Posted Jul 01, 2023 - 08:33 UTC